Newbie on sound, working on a EMU and can't get the right sounds to trigger at the right time. All I'm after is matching up the wav to the speed (e.g. a1 for 2-14 mph, a2 18-24 mph, etc).

According to steam4me, I've used Speed instead of Variable2, but to no avail. It's either a0 or it replays a1 at all speeds.

Stream (
Priority ( 6 )
Triggers ( 14
Initial_Trigger ( StartLoop ( 1 File ( "a0.wav" -1 ) SelectionMethod ( SequentialSelection ) ) )
Variable_Trigger ( Speed_Inc_Past 2.00 StartLoop ( 1 File ( "a1.wav" -1 ) SelectionMethod ( SequentialSelection ) ) )
Variable_Trigger ( Speed_Inc_Past 14.0 ReleaseLoopRelease () )
Variable_Trigger ( Speed_Inc_Past 18.0 StartLoop ( 1 File ( "a2.wav" -1 ) SelectionMethod ( SequentialSelection ) ) )
Variable_Trigger ( Speed_Inc_Past 24.0 ReleaseLoopRelease () )
Variable_Trigger ( Speed_Inc_Past 26.0 StartLoop ( 1 File ( "a3.wav" -1 ) SelectionMethod ( SequentialSelection ) ) )
Variable_Trigger ( Speed_Inc_Past 47.0 ReleaseLoopRelease () )
Variable_Trigger ( Speed_Inc_Past 47.0 StartLoop ( 1 File ( "a4.wav" -1 ) SelectionMethod ( SequentialSelection ) ) )
Variable_Trigger ( Speed_Dec_Past 46.0 ReleaseLoopRelease () )
Variable_Trigger ( Speed_Dec_Past 46.0 StartLoop ( 1 File ( "a5.wav" -1 ) SelectionMethod ( SequentialSelection ) ) )
Variable_Trigger ( Speed_Dec_Past 27.0 ReleaseLoopRelease () )
Variable_Trigger ( Speed_Dec_Past 27.0 StartLoop ( 1 File ( "a6.wav" -1 ) SelectionMethod ( SequentialSelection ) ) )
Variable_Trigger ( Speed_Dec_Past 14.0 ReleaseLoopRelease () )
Variable_Trigger ( Speed_Dec_Past 14.0 StartLoop ( 1 File ( "a7.wav" -1 ) SelectionMethod ( SequentialSelection ) ) )



Thanks