Results 1 to 7 of 7

Thread: TSRE5 - Show Water ?

  1. #1
    Join Date
    Apr 2003
    Location
    New York, USA.
    Posts
    1,859

    Default TSRE5 - Show Water ?

    Hi Folks,

    Hmm - I had water before - now when I start TSRE5 - the latest - the water is not visible... After searching - the only reference I could find was for a really old version of TSRE that doesn't seem applicable - how do I show water globally ?

    Thanks...

    Regards,
    Scott

  2. #2

    Default

    Hmm, did you had an watertop.ace in "\YourRoute\ENVFILES\TEXTURES" ?

    Regards, Jan

  3. #3
    Join Date
    Apr 2003
    Location
    New York, USA.
    Posts
    1,859

    Default

    Quote Originally Posted by kapitaen View Post
    Hmm, did you had an watertop.ace in "\YourRoute\ENVFILES\TEXTURES" ?

    Regards, Jan
    Hi Jan,

    I did - but now that you mention it I was testing the water on this route while I was attempting to strip out all the old legacy MSTS stuff from the environment config files - while it worked fine in ORTS - I guess I pulled out something needed by TSRE - recovered same from backup - all good now - thanks for responding...

    It would be handy to be able to hide/display water though while working in TSRE...

    Regards,
    Scott

  4. #4

    Default

    I think you need a complete editor.env with registered water textures with given height.

    It is possible to hide the water, but only for marked tiles.



    Regards, Jan

  5. #5
    Join Date
    Apr 2003
    Location
    New York, USA.
    Posts
    1,859

    Default

    Hi Jan,

    Thanks - I'll give that a shot...

    Yeah - just an FYI - this is what I pruned it down to - "env" file - works in ORTS - not in TSRE:

    Code:
    [email protected]@@@@@@@@@JINX0w0t______
    
    world
    (
      world_water
      (
        world_water_terrain_patch_map ( 256 Wsib-W.raw )
        world_water_layers
        (
          2
          world_water_layer
          (
            world_water_layer_height ( -1 )
            world_anim_shader
            (
              world_shader ( TexDiff
                terrain_texslots ( 1
                  terrain_texslot ( SCO_WaterBottom.ace 1 0 )
                )
                terrain_uvcalcs ( 1
                  terrain_uvcalc ( 1 0 0 0 )
                )
              )
            )
          )
          world_water_layer
          (
            world_water_layer_height ( -0.5 )
            world_anim_shader
            (
              world_shader ( BlendATexDiff
                terrain_texslots ( 1
                  terrain_texslot ( SCO_WaterTop.ace 1 0 )
                )
                terrain_uvcalcs ( 1
                  terrain_uvcalc ( 1 0 0 0 )
                )
              )
            )
          )
        )
      )
    )
    Regards,
    Scott

  6. #6
    Join Date
    Oct 2015
    Location
    Poland
    Posts
    552

    Default

    It should work in TSRE, but remember that TSRE uses editor.env file.

  7. #7
    Join Date
    Apr 2003
    Location
    New York, USA.
    Posts
    1,859

    Default

    Quote Originally Posted by GokuMK View Post
    It should work in TSRE, but remember that TSRE uses editor.env file.
    Hi Goku,

    Hah - that explains it fully then - I thought only MSTS used "editor.env" - I removed it...

    Thanks for clarifying...


    Regards,
    Scott

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •