Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Odd missing track shape?

  1. #11
    Join Date
    May 2010


    And I need to back up a bit further.

    -Is MSTS installed per the instructions at Steam 4 Me for whichever OS you have?

    Thinking more on it, and IIRC, the MSTS Bin fixed this issue of paired blue poles with a white vector line becoming orphaned in one of it's last iterations. At a minimum, you need the Microsoft 1.4 Patch installed and then install the final version of MSTS Bin.

    Also be aware that placing one track piece across 3 blue tiles is a fail. (you start in or near the corner of one tile, cross the corner of a second tile, and the opposite end of the track piece lands in a third tile.) The solution there is as you said, using shorter pieces.

    Doug Relyea
    Making stuff that works, using outdated Software on outdated Hardware.

  2. #12


    Everything is as up to date as I can get it. As I can't remove the errant section, think I'll do a "what if" cutoff and avoid the area all together - and the annoying warning. Really don't want to scrap the route just because of a small issue like this. I do have the un-altered route saved for future rework as I learn more about things like this. It's all for fun anyway. Thanks for all your help though, I really appreciate it!

  3. #13
    Join Date
    Jun 2013


    Could deleting the database files and doing a manual rebuild work for this problem? I think I did that once or twice when things got out of hand

  4. #14
    Join Date
    May 2010


    It would be best to fix that now. TDB errors can accumulate and end up multiplying like rabbits when you least expect it.

    A manual rebuild would work, and from my own experience is a last resort option.

    First though, go into the RE, and at one or the other of the blue poles, place a short, straight A1t (10m, 20m etc). It should attach, since the blue pole is there, and save. Place one at the other end, and save again. This should eliminate the error message since there now is a vector segment with an associated shape at each end of the missing piece.

    Try the Track Database rebuild again. If it works, the rebuild should leave you with the two short pieces separated, which you can then delete.

    Doug Relyea
    Making stuff that works, using outdated Software on outdated Hardware.

  5. #15


    TSRE can fix errors like this. Several hundred on the PRR-Eastv2 were fixed.
    If you read through my posts at Elvas Tower I documented most of my work there.Most documented in this thread. Lot's to read but you'll be waay ahead!

    Teaser: You can remove an entire Track Vector from TDB (all track between TrackNodes) with one click. Then you select each track section in turn putting them back into the TDB. Ypo]ll

    I however before attempting any editing on your route you first create a single tile route and practice . . . a lot.

    At this stage TSRE is the only way you'll be able to recover your route . . . Oh, and also, for modding routes in the condition yours is in, in TSRE settings.txt file set this patameter "useTdbEmptyItems = false".
    TSRE has the ability to display AND edit TDB items so a good signal will display THREE visible items:
    1. The SignalShape.
    2. The Red Pyramid track marker and...
    3. The TDB icon, in this case, a black cube above the pyramid marker.

    Now . . .you can select the black cube (turns grey) and delete it from the TDB.
    This has very serious implications, Number one is an 'Orphan' Signal, sginal shape OK but no TDB entry. Wont show in Track Monitor.
    The opposite of this is also true, that is a signal seen in the Track Monitor but no signalshape seen in the sim or the editor.

    TSRE gives you the ability to correct all these type of errors but it will take you at least 2 to 3 months of practice. TSRE is SO much more powerful than the MSTS editor it's a biy scary at first.
    That's why I respectfully counsel you to take the slow and steady path.
    Open Rails Track Viewer Utility also has the display of TDB items but no editing.

    Stick with MSTS if you desire to but experience has show me it will be a tough exercise. I started practice with TSRE and have had many, many a back and forth with the developer. It's ready for prime time sir. The PRR-Eastv2 proves that.
    IMO, it's worth a shot to recover your route.

    ............Vince ..............
    ...... Author NECv4 .......
    .... LIRR BUILD PHOTOS ....
    .............LIRR VIDEO.............
    ...... Eschew Obsfucation ......

    On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
    "Give me your tired, your poor, your huddled masses yearning to breathe free,
    the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
    I lift my lamp beside the golden door!"

  6. #16


    After several tries with RE, the track rebuild now crashes the game within the first 10 seconds of scan. Can't use TSRE as it won't load. Had it a few years ago, but created havoc with the computer - so I got rid of it. Tried downloading and installing it again, won't even download now. Oh well. I'll keep hammering away at different ideas.

    Adding a small A1t 10m doesn't relieve me of the shape data warning and the gray line and blue poles are still there...even if no other track section is attached.
    Last edited by notch8; 02-17-2020 at 09:43 PM. Reason: Additional info

  7. #17


    Howdy !...If I'm not mistaken, are you not supposed to remove the existing TDB , RDB and also the TDB.BK and RDB.BK files before doing a track rebuild in MSTS RE !?


  8. #18


    No worries. Taking some artistic license with the problem area and doing a re-route around it. It's the middle of South Dakota, it's all flat and farm field. I'm not really missing anything LOL.

    I had read in the Steam 4 Me page that the .bak, .rdb, .tdb, .tit, and .rit was to be removed as a final solution. Tried this and the route failed to open. Reloaded a copy of the saved route and have moved on from there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts