Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: TSRE Crash using Error Display > [Select Object]

  1. #1

    Default TSRE Crash using Error Display > [Select Object]

    Goku,

    Using v698 Tools > Errors and Messages > I select firts object listed then Jump Button to the location. \

    In this case it is an animated switch stand (very common in NEC & PRR) When I press [Select object] button TSRE crashes.
    I have attached a zipped copy of the TSRE log.txt file.

    ATTACH]78862[/ATTACH]

    Nice work on the error thing. I was able to use it to fix several objects 'Too Far From Tile' warnings but the PRR is the first I've tried with true database errors.
    I'm presently working through the list of 'Signal not referenced to Signal Shape errors. First one blew up . . . we'll try a few more.

    regards,
    Attached Files Attached Files
    ............Vince ..............
    ...... Author NECv4 .......
    .... LIRR BUILD PHOTOS ....
    .............LIRR VIDEO.............
    ...... Eschew Obsfucation ......

    On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
    "Give me your tired, your poor, your huddled masses yearning to breathe free,
    the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
    I lift my lamp beside the golden door!"

  2. #2
    Join Date
    Dec 2006
    Location
    .
    Posts
    11

    Default

    I've also noticed the problem Vince mentions. But if you deactivate "Tools / Properties" you can select the object and jump to it. When activating "Tools / Properties", TSRE crashes

  3. #3

    Default

    Verified.
    ............Vince ..............
    ...... Author NECv4 .......
    .... LIRR BUILD PHOTOS ....
    .............LIRR VIDEO.............
    ...... Eschew Obsfucation ......

    On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
    "Give me your tired, your poor, your huddled masses yearning to breathe free,
    the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
    I lift my lamp beside the golden door!"

  4. #4

    Default

    Adding more info. For the moment I'm working on the easy part . . . Removing objects too far from tile. Floating trees/veg/cars/fences @ 10 Km altitude or buried a Km or more underground.

    I've been able to 1. jump to these objects, 2. select them with the Error Panel, but cannot delete them until I access the pop up menu and do a 'Reset Rotation on the selected (blue outline) object.
    Then I can translate (move) the object and now the delete key works.
    This is a valuable tool but it needs a bit of works yet.

    regards,
    ............Vince ..............
    ...... Author NECv4 .......
    .... LIRR BUILD PHOTOS ....
    .............LIRR VIDEO.............
    ...... Eschew Obsfucation ......

    On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
    "Give me your tired, your poor, your huddled masses yearning to breathe free,
    the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
    I lift my lamp beside the golden door!"

  5. #5
    Join Date
    Oct 2015
    Location
    Poland
    Posts
    601

    Default

    Quote Originally Posted by Vince View Post
    In this case it is an animated switch stand (very common in NEC & PRR) When I press [Select object] button TSRE crashes.
    I have attached a zipped copy of the TSRE log.txt file.
    Selecting broken items may cause TSRE Properties window to crash . I just fixed it for platform object:
    http://www.onrails.eu/viewtopic.php?f=7&t=107&start=10
    It will be fixed in the future for other items.

    I've been able to 1. jump to these objects, 2. select them with the Error Panel, but cannot delete them until I access the pop up menu and do a 'Reset Rotation on the selected (blue outline) object.
    You should be able to delete it just by giving focus to 3D view. Use one right button click.
    In the future there will be a "delete" button in Properties window.

  6. #6

    Default

    Good morning Goku,

    Thank you for your attention. I'll try the single right click to set focus / / / did have focus but no delete until I used the Reset Rot Button on properties panel.
    Pointer in Stick everything mode pointer does collide (show) correctly on the object.

    Any advice on these in pic?
    TsreErrorPanel.jpg
    These are the ones that crash if properties are open.These signals, at least the four or five I've run trains through operate normally. The first (hylited) is a switchstand and animates normally. As soon a I select either bt the Select Key on Panel or use pointer to select . . . a 3-4 second pause then the Crash message displays.

    regards,
    Last edited by Vince; 04-09-2020 at 08:17 AM.
    ............Vince ..............
    ...... Author NECv4 .......
    .... LIRR BUILD PHOTOS ....
    .............LIRR VIDEO.............
    ...... Eschew Obsfucation ......

    On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
    "Give me your tired, your poor, your huddled masses yearning to breathe free,
    the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
    I lift my lamp beside the golden door!"

  7. #7

    Default

    Quote Originally Posted by Vince View Post
    Good morning Goku,

    Thank you for your attention. I'll try the single right click to set focus / / / did have focus but no delete until I used the Reset Rot Button on properties panel.
    Pointer in Stick everything mode pointer does collide (show) correctly on the object.

    Any advice on these in pic?
    TsreErrorPanel.jpg
    These are the ones that crash if properties are open.These signals, at least the four or five I've run trains through operate normally. The first (hylited) is a switchstand and animates normally. As soon a I select either bt the Select Key on Panel or use pointer to select . . . a 3-4 second pause then the Crash message displays.

    regards,
    Does it do the same in route riter ICHK?

    I have noted these issues when placing signals close to tile boundaries. TSRE writes the TDB entries to the adjacent tile (with coordinates larger than 1024/-1024) for the signal while the world file entries are written in the correct tile, hence resulting in an error when ICHK is run.

    Placing the same signal in MSTS does not result in this behavior.

    The signal works fine in game though, so I've left it as that. Reported it once back somewhere here.

  8. #8
    Join Date
    Oct 2015
    Location
    Poland
    Posts
    601

    Default

    Quote Originally Posted by Vince View Post
    Thank you for your attention. I'll try the single right click to set focus / / / did have focus but no delete until I used the Reset Rot Button on properties panel.
    Works for me. Don't know what you are doing wrong here.

    Quote Originally Posted by Vince View Post
    Pointer in Stick everything mode pointer does collide (show) correctly on the object.
    Why you write about it here? ....

    Quote Originally Posted by Vince View Post
    Any advice on these in pic?
    TsreErrorPanel.jpg
    These are the ones that crash if properties are open.These signals, at least the four or five I've run trains through operate normally. The first (hylited) is a switchstand and animates normally. As soon a I select either bt the Select Key on Panel or use pointer to select . . . a 3-4 second pause then the Crash message displays.
    It means that signal filename found in W file can't be found in sigcfg file.

  9. #9

    Lightbulb TDBItems Display Needs Properties.

    Quote Originally Posted by GokuMK View Post
    Works for me. Don't know what you are doing wrong here.


    Why you write about it here? ....


    It means that signal filename found in W file can't be found in sigcfg file.
    That's not what I see. All these signals do exist in the Sigcfg file, They've been in there for ages!
    When I use the Jump button after high lighting the error on the top line the location is a ABS B&O color position light that I originally installed when I built the NECv4 route.

    These are signals that have worked properly for over 10 years. They are now incorporated into the PRR-East v2 route without any changes.

    Something else is wrong here.

    First off, there were two TBDItems displayed as the Black Cube, superimposed over each other.

    I can select one, delete it after the warning message and there is ANOTHER black cube that was superimposed over the black cube at the same location where I deleted the first TDB Item.
    This is EXACTLY why I asked you many months ago to provide a Properties Display for ant TDBItem displayed.

    So now it looks like each of these 'errors' are two TDBItems superimposed over each other and selecting them provides no information as to what they may be.

    The TDBItem display is useful but without an ID of the Items properties deleting such items is a crap shoot, not something one should do in the Track Database.
    When selecting a TDBItem I'd very much like to see a way to display all relevant properties of the Item.

    Next: Pointer Stick . . .
    Why you write about it here? ....
    These are objects listed in the Error Panel as "Too Far From Tile Border", not the Signal 'Errors'. Mostly deeply buried treelines and other scenery objects, not TDB Items.
    I only mentioned the pointer stick-to the object selected in the Error panel to illustrate to you that I CAN put the pointer on the object yet am unable to deselect it or delete . . . unless . . . I first bring up the context menu where I can use a Reset Rotation button. Then I am able to successfully delete all objects listed in the Error Panel as "Too far from tile border".
    Thanks for your attention Goku. Stay well.
    regards,
    Last edited by Vince; 04-13-2020 at 02:26 PM.
    ............Vince ..............
    ...... Author NECv4 .......
    .... LIRR BUILD PHOTOS ....
    .............LIRR VIDEO.............
    ...... Eschew Obsfucation ......

    On the The Statue of Liberty in New York Harbor there is a Tablet. On it is written:
    "Give me your tired, your poor, your huddled masses yearning to breathe free,
    the wretched refuse of your teeming shore, send these, the homeless, tempest-tossed to me,
    I lift my lamp beside the golden door!"

  10. #10
    Join Date
    Oct 2015
    Location
    Poland
    Posts
    601

    Default

    Quote Originally Posted by Vince View Post
    That's not what I see. All these signals do exist in the Sigcfg file, They've been in there for ages!
    When I use the Jump button after high lighting the error on the top line the location is a ABS B&O color position light that I originally installed when I built the NECv4 route.

    These are signals that have worked properly for over 10 years. They are now incorporated into the PRR-East v2 route without any changes.

    Something else is wrong here.
    No, the error means precisely what I told you above. If the signals are 100% good in MSTS/OR then it may be a TSRE sigscr bug.
    Maybe letter case in the names between .W file and sigscr file doesn't match?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •