Results 1 to 7 of 7

Thread: MSTS Signals in OR

  1. #1
    Join Date
    Dec 2006
    Location
    Brockville, ON, CA
    Posts
    2,653

    Default MSTS Signals in OR

    Hi All,

    The DAR is dart territory, no signals, but the CN Bedford Sub is signaled. Years ago when I built the first version I used Hank Sundermeyer's signals and never had a problem with them until OR, and then I just needed a new signal that told OR that the signaled region ended. Now I'm working on the DARv3 and last night added about two and a half miles to the west end of the CN Bedford Sub to the west limits of CN Train 507, a way freight. Kinsac is a long passing siding off a single track main with a short siding at the west end in CTC territory.

    I've added the signals CN used according to a track profile. I'm using Permissive signals and they work fine in MSTS but not so much in OR. The two head Permissive signal in MSTS changes to yellow over red when I throw the switch to the passing siding as expected, but in OR it goes to red over red.

    Just wondering if this is a known issue with OR or maybe just something in the older version I'm using... 1.3.4310 (I've not upgraded for a while as I keep reading different issues with newer experimental versions).

    Paul :-)

  2. #2
    Join Date
    Jun 2013
    Location
    Minnesota
    Posts
    1,399

    Default

    Which set is it, exactly? I can take a look when I get home, to see if something didn't translate well between the sims. Does the log say anything?

  3. #3
    Join Date
    Dec 2006
    Location
    Brockville, ON, CA
    Posts
    2,653

    Default

    The set is slsig31 . Had no trouble over they years with it until adding the passing siding last night.

    Thanks for offering to look.

    Paul :-)

  4. #4
    Join Date
    Jun 2013
    Location
    Minnesota
    Posts
    1,399

    Default

    I've looked through his scripts, and I don't see anything that jumps out as causing a signal to drop to red in that case, but I can't really figure out the scripts completely (everyone who writes them has their own way of doing things). What exactly is the way in which you're using these signals? Maybe I can replicate it? Otherwise, I got nothing

  5. #5
    Join Date
    Dec 2006
    Location
    Brockville, ON, CA
    Posts
    2,653

    Default

    I have been tinkering with the signals all day.

    The passing siding has one two aspect Permissive signal before the switch facing into the siding. The mainline has a two aspect Permissive signal facing outward, and the siding has a one aspect permissive signal facing outward, this is the same for both ends.
    The CN profile shows a two aspect signal Permissive signal about two miles east of the siding, one facing each direction, but these are grey like they were in-active. I kept getting strange speed limits and this morning placed the two intermediate signals and that changed things for the better, I now get green over red and yellow over red where I expect to see them.

    One thing that I'm getting that I shouldn't, a speed restriction of 40 mph in a 50 zone between the new signals and the signal just before the siding even when the player path is lined on the mainline, no switches are thrown. As soon as you pass the signal near the siding the track speed goes back to 50, this is the same in either direction.

    I hate doing this but I'm going to add a signal after the previous switch before the new intermediate signals to see what that does.

    Paul :-)

  6. #6
    Join Date
    Jun 2013
    Location
    Minnesota
    Posts
    1,399

    Default

    You have permissives protecting the siding switches? I think that may be the problem. While CN might well have done that, I don't think Hank's set is really built for that. The fact that you can get the proper aspect at the distant in MSTS is probably a fluke. I think you'll have to put absolutes at the siding switches, at least the facing-point signal, to get what you want. I doubt permissives would handle meets well, anyway

  7. #7
    Join Date
    Dec 2006
    Location
    Brockville, ON, CA
    Posts
    2,653

    Default

    That was my next think to change! I had very little problems with the Conn River even though it has both searchlight and semaphore signals. I loaded a copy of it into MSTS today so I could have a look at the signals and did find the sidings were abs signals.

    Paul :-)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •