Results 1 to 3 of 3

Thread: Trying to combine two different type of Tracks - Error

  1. #1
    Join Date
    Dec 2008
    Location
    Aguascalientes, Mexico
    Posts
    391

    Exclamation Trying to combine two different type of Tracks - Error

    Could please someone help in the following situation..

    I tried to combine two different types of tracks (Concrete ties US2 & Wood ties US3), what I did is I replaced in all the World files where I want to have wood example... I renamed the A1t100m for us3_a1t100 and it worked for the straight pieces of track but it didn't work for the curves..

    The TSRE shows that track was replaced with wood effectively but when I play in Open Rails curves are still showing concrete

    1.jpg

    In TSRE all tracks looks replaced fine

    2.jpg

    But running curves remain if is not respecting the us3_ that I added in the world files..

    Open Rails 2020-06-20 01-12-29.jpg

    could someone please assist?

    Thanks and regards

    rodrigoville

  2. #2
    Join Date
    May 2018
    Location
    Musterhausen
    Posts
    116

    Default

    The problem is superelevation. Currently OpenRails only supports one type of TrProfile.stf /.xml for Dynamic Track per route. Because superelevation is implemented using dynamic track, this will either happen with the US2 or the US3 curves, depending on what textures the TrProfile is linked to.
    If you haven't installed a TrProfile file for USTracks yet (available at Elvas Tower, I think), OpenRails will use the standard "Kuju" default track profile.

  3. #3
    Join Date
    Sep 2006
    Location
    .
    Posts
    2,471

    Default

    Correct, the Superelevation addition was very much a 'first draft' thing. It is nowhere near where it needs to be. Similar issues occur with ScaleRail when you deploy multiple track textures as well.




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •