Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: AI Train Speed Too Slow!

  1. #11
    Join Date
    Nov 2011
    Location
    California, USA
    Posts
    109

    Default

    The Open Rails log is unlikely to reveal anything useful. Instead, what I would do is load the game up in the Visual Studio debugger and set a breakpoint somewhere in the Track Monitor code, with the goal of revealing wherever the phantom speed post or speed signal is coming from.

    meeshu, could you also upload the path file you are using? That is the last piece of information needed to reproduce your scenario.

  2. #12

    Default

    Had NEC V4 route for many years, but only ran under MSTS as Open Rails was not available back then.

    I don't specifically recall any "phantom" 15 mph speed limits suddenly appearing on previous occasions under MSTS. But due to limitations of MSTS and my computer back then, I only ran relatively short freight trains (no more than about 100 cars).

    I run almost exclusively long and heavy freight trains on all routes now, just for fun! I don't attempt to run prototypical trains on routes. So for NEC V4 route which usually runs mostly passenger trains, I run long/heavy freight trains instead.

    Did some brief test runs on the NEC V4 route at Perryville and at Bayview with some interesting results!

    Under MSTS with default equipment consisting of 13 dash locomotives and 200 cements cars as a test consist in 6-200-7 configuration, the following was observed.

    At Perryville, the speed limit was 15 mph and the train STAYED at 15 mph even when the train cleared Perryville MOW yard and was on the mainline where the speed limit should now have been 60 mph!?

    At Bayview, the yard speed limit was 15 mph, but the Track Monitor had difficulty in deciding the speed limit between 15 mph and 60 mph for the mainline speed limit! The speed limit settled down to 60 mph, even though the train was still within Bayview yard!?

    Under Open Rails (MG and unstable versions), the respective yard speed limits were correct at 15 mph, and when the train cleared the yards, the speed limit increased to mainline speed of 60 mph. However, the Track Monitor now showed that a 15 mph speed limit was just ahead of the train!? The "phantom" 15 mph speed limit had suddenly appeared on the mainline for some reason.

    Here are the test paths -

    15mph_test_paths.zip

    It is pointless for me to examine Open Rails source code as I don't understand anything about it, let alone debugging it.

  3. #13

    Default

    So, has anyone figured out what is going on with the strange speed limits appearing?

    Any solutions?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •