Results 1 to 9 of 9

Thread: Open Rails NewYear MG Version 67, Physics Changed?

  1. #1

    Question Open Rails NewYear MG Version 67, Physics Changed?

    Running test trains (under NEC V4 route), I've noticed that while running under MG version 67, it is harder to start/accelerate train compared to other versions of Open Rails (1.3.1, and unstable dated 8th July).

    To get my test train accelerating, it requires throttle "3" setting under MG version 67. For other versions of Open Rails, it just requires throttle "1" setting to get my train to accelerate.

    So, have the "physics" been modified in MG version 67 (by mistake)?

    Here is the test consist -

    4_dda40x_MP_empty_tankers.zip

    The locomotives are from here. Although any DDA40X locomotive could be used instead.

    The tanker cars are from here.
    Last edited by meeshu; 07-08-2020 at 11:58 PM.

  2. #2

    Default

    On testing with different versions of OR MG that I've downloaded, the last version (that I have) which allows train acceleration in throttle "1" is version 63.

    The next version (that I have) of OR MG that doesn't accelerate the train until the throttle is in position "3", is version 66.1.

    So after version 63, there appears to have been some changes to train (acceleration) physics. Whether these changes are intentional (or not) and realistic is unknown?

  3. #3
    Join Date
    Oct 2004
    Location
    Onalaska, Wa
    Posts
    81

    Default

    Depending on length of the train and tonnage, I would say having to notch the throttle to 3 is realistic to get moving.

    Sent from my SM-G988U using Tapatalk

  4. #4
    Join Date
    Nov 2011
    Location
    California, USA
    Posts
    109

    Default

    Hey, sorry for the bug - as you've deduced, the starting friction is an order of magnitude higher than it should be, because I made a mistake when merging in the new starting friction property. A fix is ready to go but hasn't yet been merged into the master branch. I believe it should reach the next NewYear MG release.

  5. #5

    Default

    Thanks for the comments!

    I was wondering whether the physics were wrong to begin with, and the physics were corrected in later releases!?
    Last edited by meeshu; 07-13-2020 at 05:29 AM.

  6. #6
    Join Date
    Nov 1999
    Location
    Torino, Italy.
    Posts
    833

    Default

    OR NewYear MG rev. 68 should include Ryan's patch.

  7. #7

    Default

    Thank you!

  8. #8
    Join Date
    Oct 2004
    Location
    Onalaska, Wa
    Posts
    81

    Default

    Issue is resolved in rev. 68.

    Sent from my SM-G988U using Tapatalk

  9. #9

    Default

    I can also confirm that my test train again accelerates using throttle "1".

    Thanks again for the correction!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •