Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Now you see it, Now you DON'T

  1. #1
    Join Date
    Jun 2003
    Location
    New Jersey, United States
    Posts
    456

    Default Now you see it, Now you DON'T

    Hello fellows:

    I'm having an interesting problem with a file set for a French rail car. The file is "x4901_auvergne.zip" which is from the
    https://www.activitysimulatorworld.n...es_et_autorail website files.

    I have downloaded the file several times, and each time I get the same result. the trainset has a motor car at each end and a regular non-powered trailer in the middle.

    When I run the set in the old MSTS Train Simulator program I have no problems with it, as in the First picture.

    When I run the SAME CONSIST in Open Rails.something strange happens.......the middle trailer car does not appear in the set, yet the entire consist moves and acts like it WAS there?? as in the SECOND picture

    Can anyone help with what is going on. Is it a problem of the ACE file for this wagon, or the Shape file, or some bug with Open Rails???
    Any help or reply is appreciated.

    MSTS Train Simulator.jpgOpen Rails.jpg
    Doug

    Happiness is when the AI-trains appear where you want them to

  2. #2
    Join Date
    Sep 2006
    Location
    .
    Posts
    2,480

    Default

    The only thing strange is the chronic refusal to understand

    no log = no help

  3. #3
    Join Date
    Feb 2008
    Location
    Lexington, Ky
    Posts
    2,630

    Default

    It is probably a .wag file issue and your link goes to a 403 Forbidden page error.
    Rick

    http:\\mononrr.com

    MONON-2


  4. #4
    Join Date
    Sep 2006
    Location
    .
    Posts
    2,480

    Default

    Could also be an .sd file issue too.

    MSTS needs an .sd file present, while Open Rails does not. But some older MSTS-era utilities that test for consist, wagon an engine file integrity do need to see the presence of an .sd file.


    If the .sd file looks like this, everyone is happy

    [email protected]@@@@@@@@@JINX0t1t______

    Shape ( CR_STEEL_SLAB_GON_589002.s
    ESD_Detail_Level ( 0 )
    ESD_Software_DLev ( 3 )
    ESD_Alternative_Texture ( 0 )
    ESD_Bounding_Box (
    -1.57102 0.0 -8.034
    1.57102 4.483 8.034 )
    )




    If the .sd file looks like this

    [email protected]@@@@@@@@@JINX0t1t______

    Shape ( CR_STEEL_SLAB_GON_589002.s
    )

    both the utilities and open rails is happy, MSTS not so much




    If the .sd file is just a placeholder that looks like this

    [email protected]@@@@@@@@@JINX0t1t______

    Then the utilities are happy, but Open Rails and MSTS are not. Open rails will preserve the consist spot but not show the relevant car.




    If you outright delete the .sd file, Open Rails is happy, but the utilities and MSTS are not.



    So my question is - If Open Rails can run without an .sd file, why is it busy doing integrity testing on that .sd file and keeping the car from showing if an .sd file is there but is inadequate or otherwise missing a proper shape line? Why does Open Rails need to see specific content in an .sd file when it can run fine without one if you simply zap the .sd file into the trash?

    Fun fact! OpenRails evidently does integrity testing on files it doesn't need - the things that baffle you.

  5. #5
    Join Date
    May 2010
    Location
    Northern Virginia, United States of America
    Posts
    1,705

    Default

    I would also speculate the possibility of it being an issue with the .s file of the trailer. It would explain the invisibility while still showing the train as if the car was there.

    All of this is only speculation though, Run OpenRails with the train again, but make sure the "Logging" check box is checked. Once it's loaded, and the trailer isn't present, close the sim and upload the OpenRailsLog.txt (on your desktop, most likely) to the forums here as an attachment on a post replying to this thread. This log file will probably pinpoint where the problem is.

  6. #6
    Join Date
    Feb 2013
    Location
    known universe
    Posts
    2,034

    Default

    I wonder if it is like the default SD40? that had the misplaced or extra bracket in the shape file that caused it to disappear in the sim? That error was replicated in every model that used that shape file.
    Cheers, Gerry
    It's my railroad and I'll do what I want! Historically accurate attitude of US Railroad Barons.
    Forever, ridin' drag in railroad knowledge.


  7. #7
    Join Date
    Nov 1999
    Location
    Doreen, Victoria, Australia.
    Posts
    6,750

    Default

    It was a \ actually, found another one 3 days ago in an sd40 while setting up an activity for Ohio Rails.

    You can find it by searching for )\
    Cheers
    Derek

  8. #8
    Join Date
    Jun 2003
    Location
    New Jersey, United States
    Posts
    456

    Default Now you see it, Now you DON'T

    As requested heere is the OR log file from starting up the program with the object consist in question.

    OpenRailsLog.txt
    Doug

    Happiness is when the AI-trains appear where you want them to

  9. #9
    Join Date
    Oct 2007
    Location
    Iggesund, Sweden
    Posts
    60

    Default

    First of all try this link and then hit Union Jack: https://www.activitysimulatorworld.net/ Check what they have in OR maybe this DMU is there. Can't help you on OR since I using my old Windblows XP for MSTS. Since I've some French routes with this DMU in red motor & driving car me figured out to drive from the other way is hit F9 and click on that non driving car then using 5 to lock out from the cab. But since you have a motorcar in both end so try to place in consists 1st car (copy of) last and reverse it. Yes I know this is not what you asking for but may helps ome others.
    Last edited by Lurker57; 09-20-2020 at 08:47 AM.

  10. #10

    Default

    I could not find your x4901 at https://www.activitysimulatorworld.n...l_Francais.htm which has 17 pages of downloads. Which page is this file on?

    What is the link for x4901_auvergne.zip?

    I did find an x4901 at https://www.lescompagnonsdurail.fr/les-caravelles

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •