On explore mode the blue station icon on the track monitor doesn't appear. There a setting to fix that? I don't want to unexpectedly overrun stations.