Results 1 to 9 of 9

Thread: Western Railways all versions have an issue with unwanted files in some route folders

  1. #1

    Default Western Railways all versions have an issue with unwanted files in some route folders

    G'day All, I have been trying to get Western Railways V2, V6 and V7 to run smoothly and up until today I was having no luck. It turns out that the shapes and textures folders had quite a number of files in them that did not belong, I found this out when I ran sms_Checker and saw that there were files there which were from locos and other stock which were calling for files they could not find.
    After getting rid of these pesky files the route is running much smother and the frame rates have increased nicely, these files are present right back to the original V2.
    If you have doubts install from the zip files and take a look. Easiest way is to find them is to go to the shapes and textures folders and click on the "Type" button and it makes them easy to find.
    Regards and good luck.
    Barrie

  2. #2

    Default

    G'day All, I have now sorted through my various installs of Western Railways and now have just the three installs, Western Railways V2, V6 and V7 (I use OR) all sorted and going nicely, the clean out of copies of failed versions cleared out a nice 44gig so now have some more play room. I will rum a defrag overnight and things should be as good as gold.
    Regards
    Barrie

  3. #3
    Join Date
    Sep 2005
    Location
    Auckland, New Zealand.
    Posts
    242

    Default

    Don't understand this at all. sms_checker checks sound files, i.e. .sms and the associated .wav files.

    These have nothing to do with the shapes and textures folders and probably very little to do with how smoothly a route runs.

  4. #4

    Default

    Quote Originally Posted by latimers View Post
    Don't understand this at all. sms_checker checks sound files, i.e. .sms and the associated .wav files.

    These have nothing to do with the shapes and textures folders and probably very little to do with how smoothly a route runs.
    G'day latimers, yes I would agree except that these files sms_checker found are 18 .eng and 19 .wag all of which call for sound assets which they cannot find, this is why sms_checker came up with errors in these folders. Upon removing the problem files (130 in all) there were no more of these errors and the routes performance in OpenRails has improved.
    I discovered this by accident using sms_checker to find sound issues otherwise I would have never bothered to look in those folders.
    It is very much up to the individual whether they do anything or not, I could have just sat back and not worried about anyone else but I remember how others had pointed out problems which assisted me to improve things.
    Regards
    Barrie

  5. #5
    Join Date
    Sep 2005
    Location
    Auckland, New Zealand.
    Posts
    242

    Default

    I still don't understand.

    So you ran sms_checker and it told you you had problems in your shapes and textures folders? That's not possible.

  6. #6
    Join Date
    May 2010
    Location
    Worksop, UK
    Posts
    2,195

    Default

    Ah!! Barrie must have found my secret button!!

    Just joking, Bob None of my utilities will identify unused textures or shapes, and sms_Checker certainly doesn't read .eng or .wag files, so I think Barrie is getting confused with some other utility.

    Cheers,
    Ged

  7. #7

    Default

    G,day all, I have done a fresh install of Western Railways V2 to V6 with all updates and scenery patches. I then checked it with sms_Checker, attached is the report. This can be replicated by anyone, just install the route and do the check.
    Regards
    Barrie
    Attached Files Attached Files

  8. #8
    Join Date
    May 2010
    Location
    Worksop, UK
    Posts
    2,195

    Default

    Hi Barrie,
    Sorry, mate, but .sms files shouldn't be in the Shapes or Textures folders! They do absolutely nothing there and should all be moved to their correct location, which will be either the common.sound folder or the appropriate loco's SOUND folder.

    Cheers,
    Ged

  9. #9
    Join Date
    Nov 1999
    Location
    Chippenham, Wiltshire, UK.
    Posts
    6,931

    Default

    I have just checked the v2 archive files and confirm that there are indeed two locomotive sets in the texture and shapes folders of the version 3 update. As to what folder they should be in, no idea right now as there are several options depending on who made the original model, and the subsequent repaint.

    EDIT:
    It is possible that these locomotives are supposed to be static eye candy, in which case you dont need textures in a shapes folder, shapes in a texture folder or sound files in either.
    Last edited by baldwin; 12-07-2020 at 08:52 AM. Reason: Had a thought
    Beer is not a matter of life or death, it is much more serious than that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->