Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Make Ace not working right

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Default Make Ace not working right

    MakeAce seems to have stopped fully working on my windows 10 system for no reason I can discern (which means it is probably an update). The result is that neither AceIt nor TGATool2 can save an .ace file with an alpha layer.

    I tried re-installing the programs, but the behavior is the same.

    Anybody know what is going on and how to solve it?

    thanks
    Christopher

  2. #2

    Default

    You might need to adjust the compatibility settings -- I recently had similar issues with TGATool2A and ACE files, and updated both applications to "Run as Administrator" to get things to behave correctly again.

  3. #3

    Default

    I do not see any registry entries for MakeAce or TGATool2. Unless they are under a name I don't recognize or a section I didn't expect (I looked in all the "software" folders)
    thanks
    Christopher

  4. #4
    Join Date
    May 2010
    Location
    Montreal, QC
    Posts
    20

    Default

    I took notice of this and the other recent thread with some concern as I run win10 and have a big ace reskin project on pause at the moment. I use TGAtool2 - AceIt! version and thankfully for me at the moment at least it seems to still be able to export them with alpha on my system, much the same as some other users have reported.

    I keep my windows up to date too. I wonder if your alpha saving problem could be an unexpected behaviour of an antivirus operation or a similar windows defense mechanism?

  5. #5
    Join Date
    Nov 2007
    Location
    SW MO
    Posts
    499

    Default

    I have two computers that I use for ORTS/TSRE.
    The one on the right, that I use for stuff when the two screens on the left are full, started having issues with AceIt and TGAtool won't even open. Started about two weeks ago. It had had a "Feature" update recently.
    The next day this showed up on my Reddit feed.
    Turns out you don't have to have the Feature update so I dialed back my main computer to 1904. It's had an update since then but everything still works.

    Sorry, this only works on 10 Pro.

    Randy

  6. #6

    Default

    Quote Originally Posted by lrc2 View Post
    I took notice of this and the other recent thread with some concern as I run win10 and have a big ace reskin project on pause at the moment. I use TGAtool2 - AceIt! version and thankfully for me at the moment at least it seems to still be able to export them with alpha on my system, much the same as some other users have reported.

    I keep my windows up to date too. I wonder if your alpha saving problem could be an unexpected behaviour of an antivirus operation or a similar windows defense mechanism?
    A word of warning. Windows 10 updates hate old programs that were run on XP up to Windows 7. The update tends to outright delete the program or remove some key element's like say .dii and.dat files thus making the program useless. Not all users experience this with a Windows 10 update. A update killed my 3DC 9.3. What I did was installed an app to outright turn off the Microsoft update. After that I installed another app so I could delete all the Windows 10 updates and low and behold 4 key files returned for 3DC. It worked again. I did this maybe 2 years ago. Have since bought a new computer and installed the same apps, removed the updates. I have had no issues on two computers over 2 years with having the updates turned off. So that's my 2 cents.

  7. #7

    Default

    Thanks
    I looked again and permissions seem fine. Using "run as administrator" has the same problem.
    It is odd that it would just be the alpha channel. One would think a problem would block the program from functioning in its entirety. Unless it is a Direct X update issue that only affects alpha channels.
    Christopher

  8. #8
    Join Date
    Feb 2005
    Location
    belo horizonte, minas gerais, brasil
    Posts
    440

    Default

    Some files do not really accept ALPHA INSERT / MODIFICATION. I've been trying something similar for several weeks
    Chimbica Dash8

  9. #9
    Join Date
    May 2010
    Location
    Worksop, UK
    Posts
    2,254

    Default

    Hi Christopher,
    I doubt if it's anything to do with a Win 10 update - are you certain that your source file actually has an alpha channel?

    My Windows 10 is updated to the latest version (20H2) and I've just successfully exported a texture file with alpha channel from TGATool2A. To ensure that the problem is not with your TGATool2A, or your original file, may I suggest that you try with a file known to have an alpha channel - I used class5003.ace from the default Class50 and exported it as class5003a. The 'new' file still contains its alpha channel and shows correctly in the Sim (after renaming!!).


    Cheers,
    Ged

  10. #10

    Default

    I'm tearing my hair out about this and still haven't solved it.

    The problems seem to have started when windows 10 updated. There were several other problems that started at the same time:
    - I have an HD monitor and had reset things so a few programs such as my old photoshop would scale up since they couldn't cope with the extra pixels in an HD view. After the windows update, this went away and I had to reset properties for these programs
    - Goku's little modification to allow .ace files to be viewed in the windows explorer preview pane stopped working. I had to reinstall and now it is working again.
    - MakeAce no longer saves the alpha layer when opening in the context menu
    - AceIt also no longer saves the alpha layer
    - TGATool2 no longer saved the alpha layer
    - TGATool2 no longer sends the file to the editing program (photoshop). Photoshop opens but with no file.

    I did reinstall MW's .dll files. Now TGATool2 is not saving at all.

    I'm mystified.
    Last edited by conductorchris; 01-09-2021 at 12:11 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->