Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 25

Thread: Make Ace not working right

  1. #11
    Join Date
    May 2010


    Hmmm. And this isn't an idle question.

    Does the Windows Registry show that's the folder TGATool2 and MakeAce are registered to, or are they in a different folder?

    Making stuff that works, using outdated Software on outdated Hardware.

  2. #12


    I do not see any registry entries for MakeAce or TGATool2. Unless they are under a name I don't recognize or a section I didn't expect (I looked in all the "software" folders)

  3. #13
    Join Date
    May 2010
    Montreal, QC


    I took notice of this and the other recent thread with some concern as I run win10 and have a big ace reskin project on pause at the moment. I use TGAtool2 - AceIt! version and thankfully for me at the moment at least it seems to still be able to export them with alpha on my system, much the same as some other users have reported.

    I keep my windows up to date too. I wonder if your alpha saving problem could be an unexpected behaviour of an antivirus operation or a similar windows defense mechanism?

  4. #14
    Join Date
    Nov 2007
    SW MO


    I have two computers that I use for ORTS/TSRE.
    The one on the right, that I use for stuff when the two screens on the left are full, started having issues with AceIt and TGAtool won't even open. Started about two weeks ago. It had had a "Feature" update recently.
    The next day this showed up on my Reddit feed.
    Turns out you don't have to have the Feature update so I dialed back my main computer to 1904. It's had an update since then but everything still works.

    Sorry, this only works on 10 Pro.


  5. #15


    I'm tearing my hair out about this and still haven't solved it.

    The problems seem to have started when windows 10 updated. There were several other problems that started at the same time:
    - I have an HD monitor and had reset things so a few programs such as my old photoshop would scale up since they couldn't cope with the extra pixels in an HD view. After the windows update, this went away and I had to reset properties for these programs
    - Goku's little modification to allow .ace files to be viewed in the windows explorer preview pane stopped working. I had to reinstall and now it is working again.
    - MakeAce no longer saves the alpha layer when opening in the context menu
    - AceIt also no longer saves the alpha layer
    - TGATool2 no longer saved the alpha layer
    - TGATool2 no longer sends the file to the editing program (photoshop). Photoshop opens but with no file.

    I did reinstall MW's .dll files. Now TGATool2 is not saving at all.

    I'm mystified.
    Last edited by conductorchris; 01-09-2021 at 12:11 PM.

  6. #16


    Something else. After some more fiddling and a rebook, I can now get "Send Main Image to Editor" function to work, but it opens photoshop with the tiny un-scaled unreadable menu font not fit for my HD screen. Yet opening photoshop on it's own opens it with properly scaled menu fonts. "Send Main Image to Editor" does not work if I had already opened photoshop with the scaled view. It seems that the scaling of the view is interfering with opening the file.

    I think Windows 10 changed how it handles to scaling for HD screens.

  7. #17
    Join Date
    Apr 2003
    New York, USA.


    Hi Christopher,

    Hmm - odd - I have the latest patches on two Win10 boxes - no issue with either ACEIT or TGATOOL2 - sorry for you issues...

    I just tested both on 2560x1440 resolution.


  8. #18


    Reading the documentation has me wondering if DirectX got changed in some way that is causing problems? But here I am out of my depth.

  9. #19


    I'm still trying to sort this out. If anyone has any ideas, I'd be grateful. I'm really stumped.

    I read that it is possible that windows 10 updates can mess with permissions.

    TgaTool lives in a folder in DOCUMENTS. I noticed that both DOCUMENTS and the TgaTool folder are "read only" in properties, which I seem to be unable to change. But my users (I have a regular user and an administrator account) both have full permissions so I hadn't noticed anything amiss. FFEDIT is also in this folder.

    I had a wierd but transient issue. Rick shared some files he'd done. I went to copy them from my DOWNLOADS folder into my BLWZT folder, but the .ace files would not copy. The error message said I did not have permissions to do so. I rebooted and it then worked with no problems.

    "Controlled Folder Access" is off.


  10. #20


    wandering around trying things, I found this in the tgaTool help file:

    MakeAce has not proved to be one of the most unbreakable programs ever. It has been known to suddenly stop working for no apparent reason. In fact it uses many DirectX functions internally so changes to your DirectX setup (which may be made by other programs without telling you) can stop it working.

    If you get an error dialog when exporting in Ace format then MakeAce has done its trick of getting messed up by some change in DirectX or the installation of a new Graphics card.

    To get it working again you need to run the DXDIAG program (select Run from the Windows Start menu and type DXDIAG). Go to the Display tab and disable DirectDraw Accelleration. MakeAce should now start working again. You can then re-enable DirectDraw Accelleration and it should still continue to work.
    I followed these steps (not easy on windows 10) and it successfully fixed the problem with tgaTool.

    However AceIt is still not saving the alpha layer when it saves an .ace file. I reinstalled it again for good measure, but it is still not working.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts