Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: Looking for Graphics Card Suggestion

  1. #11
    Join Date
    Jun 2009
    Location
    Oshawa ON
    Posts
    1,713

    Default

    Hello, I am experiencing some lag in Graphics performance with OR/MSTS. I discovered that my present video card ( NVIDIA GeForce GTX 645 (2.0 GB RAM) (nvlddmkm 27.21.14.6192) ) is no longer supported for upgrades. Now I am looking for a reasonably priced one here in Ontario Canada. I am a Senior on a fixed income, so some of the ones recommended are either not available or out of my price range.
    I did find a newer one that is in my price range and available, MSI GeForce GT 710 2GD3 LP 2GB 64-Bit DDR3 PCI Express 2.0 HDCP Ready Low Profile Video Card (GT 710 2GD3 LP).
    An opinion please if this card is suitable for a replacement? At least is upgradeable and supported (for now :-) )

  2. #12
    Join Date
    May 2010
    Location
    Worksop, UK
    Posts
    2,268

    Default

    Hi Don,
    Looking at the 645/710 comparison charts, the 645 is a MUCH better and faster card. For instance, it has fast GDDR5 RAM against DDR3 of the 710. Additionally, the 710 is an Entry Level card whereas the 645 is an OEM fast Middle Class card. PLEASE do not even THINK of getting a 710!!

    One thing to look for with NVIDIA cards is the last two digits of its number; 10 is the base, ie lowest, level. For a long time now, I've been using a 750ti 2GB for MSTS/ORTS and have had no problems with it; it can be obtained here for about 50GBP. So long as the last two digits are 50, or greater, you should be OK.

    Later cards, like the 1030 and 1050 are rather pricey, with the former (slightly better than the 645) obtainable at about 100GBP.

    Hope this helps

    Cheers,
    Ged
    Last edited by slipperman; 05-10-2021 at 02:27 PM.

  3. #13
    Join Date
    Jun 2009
    Location
    Oshawa ON
    Posts
    1,713

    Default

    So, the card I have now, the 645 is faster and better? The issue I am having, and the reason I went to the site to update, is notchy scenery production. That is when I am running an activity it takes a while to produce the scenery, and it disappears quickly when the train passes. This happened today on Metro-North, but happens on other routes as well.
    Your information is helpful however, now I will go take another look. Thank you for the prompt response. What do you think of this one.
    The Supplier near me has this one in stock, barely in my price range:
    ASUS GeForce GT 1030 Phoenix Fan OC 2GB (PH-GT1030-O2G) - 1278 MHz Base/ 1531 MHz Boost, 6008 MHz Memory - PCI-E 3.0, 1x DVI-D, 1x HDMI.



    Last edited by Don6218; 05-10-2021 at 03:04 PM.

  4. #14
    Join Date
    May 2010
    Location
    Worksop, UK
    Posts
    2,268

    Default

    Hi Don,
    Sorry, I missed an important point in my last post

    Whichever replacement card you get, ensure that your existing Power Supply Unit (PSU) can supply the required power. According to NVIDIA data, the 645 requires a PSU rated at 450W, but it might be downrated by the original manufacturer. You need to check the label on your actual PSU. The 750 requires a 450W PSU together with an additional 6-pin power connector.

    Cheers,
    Ged

  5. #15
    Join Date
    Jun 2009
    Location
    Oshawa ON
    Posts
    1,713

    Default

    Ok, thank you for that. Here is what the computer is:
    Processor = Intel(R) Core(TM) i5-7400 CPU @ 3.00GHz (4 threads, 4 cores, 3.0 GHz) (L1 Cache 256 KB) (L2 Cache 1024 KB) (L3 Cache 6144 KB)
    I have a 430w Power supply available with a 6 pin PCI-E Connector. This one has no fan, and would be an alternate one:
    ASUS GeForce GT 1030 LP 2GB (GT1030-2G-CSM) - 1228 MHz Base/1506 MHz Boost, 3004 MHz Memory - PCI-E 3.0, 1x DVI-D, 1x HDMI.
    Last edited by Don6218; 05-10-2021 at 03:51 PM.

  6. #16
    Join Date
    May 2010
    Location
    Worksop, UK
    Posts
    2,268

    Default

    Hi Don,
    You really need to hear from somebody who is using that card with MSTS/ORTS. I have a suspicion that it's not designed for gaming (even MSTS!) but more for one of those multimedia PCs.

    Regarding the problem you're having with your 645 - is this with MSTS or Open Rails? If it's with MSTS, may I suggest that you attempt to run the same Activity/Explore Path with OR to check if the same problem occurs. If it doesn't, it could be that MSTS is having difficulty processing the installation.

    Cheers,
    Ged

  7. #17
    Join Date
    Feb 2013
    Location
    known universe
    Posts
    2,313

    Default

    If you change out graphics cards you might have to get a new power supply for the new card...also some cards might not be compatible with your current cpu. Ged or one of the other members would know more about this than me, I happened to run into a similar situation when upgrading my older desktop to a new card and still keep WIN7 OS.
    Cheers, Gerry
    It's my railroad and I'll do what I want! Historically accurate attitude of US Railroad Barons.
    Forever, ridin' drag in railroad knowledge.


  8. #18
    Join Date
    Jun 2009
    Location
    Oshawa ON
    Posts
    1,713

    Default

    I only use Open Rails. The card I have is longer supported, so I figure a newer card will do no harm. I will find out from the supplier, they are very good at explaining things, about the power supply.

    I have noticed that while the scenery takes a bit of time to generate, OR is maintaining 55-70 FPS all the while. My setting in the OR chart is 65 FPS and Scenery to the Horizon.

  9. #19
    Join Date
    May 2010
    Location
    Worksop, UK
    Posts
    2,268

    Default

    Hi Don,
    The NVIDIA GTX 645 still seems to be supported by drivers issued 29 April 2021 (466.27) -
    https://www.techspot.com/downloads/d...ia-windows-10/

    Have you considered that some Open Rails settings (like Viewing Distance (m) and Distant Mountains Viewing Distance (km)) may be too high for your graphics card to handle? If they are above the default values (2000 and 40 respectively), maybe reducing them will help.

    Cheers,
    Ged

  10. #20
    Join Date
    Jun 2009
    Location
    Oshawa ON
    Posts
    1,713

    Default

    Thank you for that link Ged. All installed and hopefully updated. I am going to give it a try this afternoon.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->