Results 1 to 3 of 3

Thread: Runaway Database Rebuild

  1. #1
    Join Date
    Nov 1999
    Location
    Jacksonville,, FL, USA.
    Posts
    3,909

    Cool Runaway Database Rebuild

    Colleagues,

    I am starting a new route, so there is a work-around for the issue I will describe.

    I created the framework for the new route, and generated terrain. Now, I want to
    add two terminals to the route. (the two I just uploaded yesterday which will
    eventually appear in the "unfinished category". Both routes have a few dynamic
    pieces but one has more than the other so I elected to start with the one having
    the most dynamic pieces (Nashville Terminal) and then manually add the other.
    (Louisville Terminal). The complete route will be the mainline sub. or in L&N days,
    the Main Stem, 1st & 2nd Subs.

    I copied the world files and the routes tsection.dat file into the new route and then
    attempted a database rebuild. As there are only 15 or so world files involvled, it
    should run pretty quickly. However, it visited all world files, or at least appeared
    to and then it continued to check non-existent files etc. etc. until I just stopped the
    program. In other words, I had a runaway rebuild.

    Anyone experience this and find a solution, like is there something that must be
    present to let the rebuild process know when it has visited all world files?

    I just posed this in case others are wondering too, because I can manually
    build the databases by the tried & true, select & release method. Not a big deal
    as this is just starting a new route.

    I have supplied the terminal routes in case others want to do other routes that
    start or end at those terminals.

    J. H. Sullivan

  2. #2

    Default

    It's probably been five or six years since I've had this happen... Changing the start tile seemed to work for me.

  3. #3
    Join Date
    Nov 1999
    Location
    Jacksonville,, FL, USA.
    Posts
    3,909

    Default

    I had to do one other thing. Put a sound source on the new start tile, otherwise the rebuild crashed
    almost before it got started. Then there were a few of the usual end-end errors and this time I jotted
    down the tile name and the x-y-z coordinates within the tile and fixed the issues very quickly. So the
    south end successfully rebuilt. Since I was reluctant to do anything with the tsection.dat file, I just
    copied the north end terminal into the route and now I am doing the select/release dance.

    J. H. Sullivan

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->