Page 7 of 9 FirstFirst ... 56789 LastLast
Results 61 to 70 of 81

Thread: Adding Automatic Switch Sounds in Openrails

  1. #61
    Join Date
    May 2010
    Location
    Worksop, UK
    Posts
    2,400

    Default

    I couldn't add this to my previous message, but it might help point to where the problem lies (or not!!)

    Here's another puzzle! I copied the complete original RUEL .trk file into the OpenRails folder then added the 3 Demosound parameters (without any changes) to that file just before the final close bracket. THAT WORKS AS WELL!!

    Cheers,
    Ged

  2. #62
    Join Date
    Nov 1999
    Location
    UK.
    Posts
    753

    Default

    Curiouser and curiouser eh? I was going to try putting the sounds in the main file on Mullan but the ttype file is empty and I'm not sure what the first line should be. The ttype in the OR folder just has Track superelevation figures as well as the 2 lines for clear trees from road and rail..
    Dell Desktop. Intel i5 3.3 CPU. 8GB RAM. Nvidia GTX 1050Ti 4GB graphics. Windows Pro 64bit. RailDriver. Partridge in a pear tree...

  3. #63
    Join Date
    May 2010
    Location
    Worksop, UK
    Posts
    2,400

    Default

    Hi Nick,
    Copy the ttype.dat file from Ruel into Mullan (after backing up the original, just in case!) and see how it goes.

    There shouldn't be a ttype.dat file in the OpenRails folder!! I think you meant .trk file?

    Cheers,
    Ged

  4. #64
    Join Date
    Nov 1999
    Location
    UK.
    Posts
    753

    Default

    Yes I meant trk lol. Could you send the Ruel ttype via pm please? Or reply with the 1st line if that's all there is. The Ruel route is on my desktop pc which is at present in for repair. I only have certain routes inclu Mullan on the laptop I'm using at present.
    Last edited by niknak; 09-05-2021 at 12:54 PM.
    Dell Desktop. Intel i5 3.3 CPU. 8GB RAM. Nvidia GTX 1050Ti 4GB graphics. Windows Pro 64bit. RailDriver. Partridge in a pear tree...

  5. #65
    Join Date
    May 2010
    Location
    Worksop, UK
    Posts
    2,400

    Default

    Hi Nick,
    I don't think I can attach a file to a PM! It doesn't look as if the original file had anything in it. Attached here is my RUEL ttype.dat file.

    Cheers,
    Ged
    Attached Files Attached Files

  6. #66
    Join Date
    Nov 1999
    Location
    UK.
    Posts
    753

    Default

    Quote Originally Posted by slipperman View Post
    Hi Nick,
    I don't think I can attach a file to a PM! It doesn't look as if the original file had anything in it. Attached here is my RUEL ttype.dat file.

    Cheers,
    Ged
    It Works!! Many many thanks Ged. Now I have all my routes working with the DemoAutoSounds plus a few hints from you on what to try on any future routes I may download that need it.

    Thanks again.

    Regards, Nick
    Dell Desktop. Intel i5 3.3 CPU. 8GB RAM. Nvidia GTX 1050Ti 4GB graphics. Windows Pro 64bit. RailDriver. Partridge in a pear tree...

  7. #67
    Join Date
    May 2010
    Location
    Worksop, UK
    Posts
    2,400

    Default

    Hi Nick,
    That's great news! Glad to be able to help

    One outstanding question - are you using the 'full' .trk file in the OpenRails folder, or just the 'include' version containing only the DemoAutoSounds parameters (and, maybe, the tree clearance parameters)?

    Cheers,
    Ged

  8. #68
    Join Date
    Nov 1999
    Location
    UK.
    Posts
    753

    Default

    Hi Ged,
    In the trk file residing in the separate OR folder I have several lines of figures concerning TrackSuperElevation, plus the two tree/road clearance lines and that's all. The main trk file in the route folder contains the full listings, including the 3 lines for the DemoAutoSounds.

    Hope that helps.

    Regards,

    Nick
    Dell Desktop. Intel i5 3.3 CPU. 8GB RAM. Nvidia GTX 1050Ti 4GB graphics. Windows Pro 64bit. RailDriver. Partridge in a pear tree...

  9. #69
    Join Date
    Nov 1999
    Location
    Doreen, Victoria, Australia.
    Posts
    7,047

    Default

    Hi Nick,

    The 3 demoautosounds lines should be in the trk file in the OR folder. They are OR commands only.
    Cheers
    Derek

  10. #70
    Join Date
    Nov 1999
    Location
    Chippenham, Wiltshire, UK.
    Posts
    6,959

    Default

    It does not matter where the commands are located, if running MSTS it ignores commands it is not coded to read. Open Rails will read its commands from whatever location they are in. The Open Rails route folder is handy to use for locating the signal data files because OR treats them slightly differently there compared to them being in the route root folder.
    Beer is not a matter of life or death, it is much more serious than that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->