Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Cannot get the 3DTrains Bombardier Cab Cars to work.

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1

    Question Cannot get the 3DTrains Bombardier Cab Cars to work.

    So, I downloaded the 3DTrains Surfliner set, and was attempting to make the BiLevels and the Coaster F59s driveable. However, while I was able to make the F59s work, the BiLevels would not spawn in. I am using Open Rails without MSTS. I seem to have done everything right, reverse the .s files, put in the .eng files. But yet they would not work. Everytime I load a consist with a BiLevel leading, an error appears saying that a fatal error has occurred and the sim crashes. And in the Open Rails Log this is what appears. Using 633 as an example.
    Error: System.IO.FileLoadException: D:\TrainSimulations\trains\trainset\3DTrains_Metro link\Metrolink_633.eng ---> Orts.Parsers.Msts.STFException: "(" not found - instead found ")" in D:\TrainSimulations\trains\trainset\3DTrains_Metro link\Metrolink_633.eng:line 475
    Does anyone know what to do, I am at a loss.

  2. #2
    Join Date
    Feb 2013
    Location
    known universe
    Posts
    2,319

    Default

    Quote Originally Posted by Rayuser View Post
    : "(" not found - instead found ")" in D:\TrainSimulations\trains\trainset\3DTrains_Metrolink\Metrolink_633.eng:line 475
    Does anyone know what to do, I am at a loss.
    The above emphasized line in the log says it all: use any text editor --- ConText - Notepad++ -- whatever and open the eng file, go to line 475 or thereabouts, you have either a misplaced or missing bracket ")" that is preventing the file from loading. I have the Metrolink set but that particular eng file is not in it ( ??? why --- I don't know ) so can offer no further help.
    Cheers, Gerry
    It's my railroad and I'll do what I want! Historically accurate attitude of US Railroad Barons.
    Forever, ridin' drag in railroad knowledge.


  3. #3
    Join Date
    Nov 1999
    Location
    Doreen, Victoria, Australia.
    Posts
    6,915

    Default

    You will need to attach the complete log file and the eng file ( zipped) so we can have a look.
    Cheers
    Derek

  4. #4

    Default

    I don't know how to attach the log and eng file, because when I try to attach the log, it is too big, and the .eng file is not supported.

  5. #5

    Default

    Here is the log and the .eng file.
    Attached Files Attached Files

  6. #6
    Join Date
    May 2010
    Location
    Worksop, UK
    Posts
    2,267

    Default

    Hi,
    Those are not included in the 3DTrains Surfliner set! From where did you get the instructions to "reverse the .s files, put in the .eng files. "? Please give us the name of the file you downloaded.

    Cheers,
    Ged


  7. #7

    Default

    Quote Originally Posted by slipperman View Post
    Hi,
    Those are not included in the 3DTrains Surfliner set! From where did you get the instructions to "reverse the .s files, put in the .eng files. "? Please give us the name of the file you downloaded.

    Cheers,
    Ged

    The .eng file and its instructions is from driveablecabcar633 in the file library.

  8. #8
    Join Date
    Nov 1999
    Location
    Huntsville, AL
    Posts
    4,694

    Default

    The LOG file says the errors are in the *********601.eng NOT the **********633.eng.

    Warning: "(" not found - instead found ")" in D:\TrainSimulations\trains\trainset\3DTrains_Metro link\Metrolink_601.eng:line 474

    Warning: Expected end of file in D:\TrainSimulations\trains\trainset\3DTrains_Metro link\Metrolink_601.eng:line 477

    Error: System.IO.FileLoadException: D:\TrainSimulations\trains\trainset\3DTrains_Metro link\Metrolink_601.eng ---> Orts.Parsers.Msts.STFException: "(" not found - instead found ")" in D:\TrainSimulations\trains\trainset\3DTrains_Metro link\Metrolink_601.eng:line 475

    Attach the ******601.eng file.
    Charles

  9. #9

    Default

    Here is the 601 .eng file, although, it does not matter which one it is, they both get the same errors, the same line that causes the issue.
    Attached Files Attached Files

  10. #10
    Join Date
    May 2010
    Location
    Worksop, UK
    Posts
    2,267

    Default

    Hi,
    The download you originally specified only concerns 633 but you appear to have also used another download (sdnrscax.zip) to apply similar changes to 601.

    This problem is caused because Open Rails doesn't like the DieselEffects section with only a comment and no data!
    I suggest you remove lines 458 to 475 inclusive. from all the .eng files which show this problem.

    Cheers,
    Ged

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->