Results 1 to 1 of 1

Thread: Stumped on Timetable Mode with Pools - Need Help

  1. #1

    Default Stumped on Timetable Mode with Pools - Need Help

    Spent the last few days making a timetable for the Scenic Sub route that uses the pools function that OR allows.

    As a test I have set up two areas as storage - Bayview Yard sidings and Everett-A series of sidings, not including runarounds - and I followed the rules in setting them up:
    > Storage paths set as outbound only (unless it's turntables but I'm not going there yet lol)
    > Storage paths are single section of plain track only with no crossings, switches, junctions, etc.
    > Access paths (again, set up as outbound only) for a storage yard have access to and are merged to all defined storage paths in that yard, and all converge on a single exit point.

    All storage and access paths are correctly defined in a *.pools_or file, kept in the same directory as the timetables (.../activities/openrails). The log file shows that the pools file is located when the activity starts, and indicates no errors.

    For a test I use just a single locomotive (3DTrainsim's freeware BN F7A) and it is kept in its own *.timetable_or file by itself. That, and another timetable file containing multiple consists, are correctly listed in a *.timetablelist_or file. The multiple-consist timetable runs without issue.

    For the F7A's "#start" row command, I have entered [09:00$pool=ScenSubPools/direction=backward] without the brackets. "ScenSubPools" is the name entered in the *.pool_or file "#name" row, the first defined row in the file. I put the "backward" qualifier there just to see the effect in-game.
    I tried using 09:00 on the #start row by itself, with the rest of the $pool command entered in the row beneath with no row definition, thus acting as a continuation of the preceding row, but that had no apparent effect.

    I have a simple path defined for the F7A that runs from the exit end of the access path from the Bayview yard mentioned earlier, and terminates a short distance away.


    THE PROBLEM:

    When running the timetable, the F7A always spawns in at the beginning of its defined consist path, and never in the pool storage tracks. And it spawns in on its scheduled time only. Starting the activity in another train at an earlier time, the F7 does not exist anywhere until it is time for it to spawn in. And it's always facing forward in the path's direction of travel, never backward as entered in it's #start row.

    Specific error in the log file (attached):

    Information: Train request : BN_F7AB:Scenic_TnP from pool scensubpools : no engines available in pool, engine is created, at 08:59:55

    Information: Player train started on time


    I've entered no "force create" command in the pool_or file but the F7 spawns in anyway, whether it's player or AI controlled.

    Now I realize I'm doing something wrong but have no idea what. I've poured over the manual's timetable and pools sections multiple, multiple times. I've tried all manner of different things but to no avail. Been troubleshooting this for days now and I'm at a loss. I'm exhausted.

    If someone can please assist I would sure appreciate it.

    Thanks a million.
    Attached Files Attached Files

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->