Results 1 to 9 of 9

Thread: Steam Trains in OpenRails

  1. #1

    Default Steam Trains in OpenRails

    G'day All, I am looking foe a way to stop all of those errors reported in the openrails log file. I am not very good with technical stuff but I would like to not have all those errors so I can catch the errors pertaining to the route and missing files easy to sort out. Most of my train running is done in "Auto Pilot mode" as I can be doing other things and still enjoy my trains as well.
    I suppose I could just swap out the steam for diesel but then it would defeat the purpose of having a route made for steam.
    Regards
    Barrie

  2. #2
    Join Date
    Nov 1999
    Location
    Doreen, Victoria, Australia.
    Posts
    7,046

    Default

    Maybe if you posted a openrailslog someone could advise you what to do?
    Cheers
    Derek

  3. #3

    Default

    G'day Derek, I have just installed this route (Blue Comet Lines) and this is the first run on it. I have attached the Log file the problem I was referring to was to do with the loco it's self but there are also a lot there which I have not come across before.
    This us the type of thing that would cause me to delete a route.
    Regards and thanks.
    Barrie
    Attached Files Attached Files

  4. #4

    Default

    G'day Derek, I have attached a log file from (F:\AU & NZ\ROUTES\01_VR_North_Main\ACTIVITIES\A LONG RUN.act) this demonstrates the loco issues in the log file, the route has virtually no issues and this what I find with the older routes in Open Rails generally there is little or no issues with the routes apart from the odd missing TEXTURE or SHAPE files which are generally easily fixed.
    Regards
    Barrie
    Attached Files Attached Files

  5. #5
    Join Date
    Nov 1999
    Location
    UK.
    Posts
    753

    Default

    I always see these error lines in the log whenever I run a steam loco. AFAIK it's just one of OR's little foibles.
    Dell Desktop. Intel i5 3.3 CPU. 8GB RAM. Nvidia GTX 1050Ti 4GB graphics. Windows Pro 64bit. RailDriver. Partridge in a pear tree...

  6. #6
    Join Date
    Apr 2003
    Location
    New York, USA.
    Posts
    2,172

    Default

    Quote Originally Posted by gremlin1812 View Post
    G'day Derek, I have attached a log file from (F:\AU & NZ\ROUTES\01_VR_North_Main\ACTIVITIES\A LONG RUN.act) this demonstrates the loco issues in the log file, the route has virtually no issues and this what I find with the older routes in Open Rails generally there is little or no issues with the routes apart from the odd missing TEXTURE or SHAPE files which are generally easily fixed.
    Regards
    Barrie
    Hi Barrie,

    As one of the very very few modelers actually building steam locomotives specifically for Open Rails - my guess on the errors is that they are the result of legacy MSTS ENG files used in Open Rails. While they do run - they would run better if updated with ORTS specific values. ORTS makes assumptions when you have missing values or the values can't be determined from the legacy MSTS values. Updating ENG in ORTS is much simpler than it ever was in MSTS as the number of tunable parameters are a fraction of what they were. You can prune vast swaths of code from the old files simplifying them. There's less than a handful of US steam locomotives setup properly for ORTS physics.

    Honestly - I seldom look at the log unless I notice an issue but here's my log from my project USRA Light Mike. While I do have a few issues I need to look at - it has very few "steam" related issues. I've also attached my Mike's ENG file which is specifically setup for ORTS and uses the ORTS "INCLUDE" file structure. All the parts of the ENG file are in the INCLUDE directory in nice clearly labeled bite sized chunks and simply called from the ENG file.

    Hope this helps.

    OpenRails Log
    OpenRailsLog.txt

    Example ORTS Steam Locomotive ENG
    USRA282_Loco.zip

    Regards,
    Scott

  7. #7
    Join Date
    Feb 2013
    Location
    known universe
    Posts
    2,476

    Default

    I echo Scott's post, while I most often run diesel I took a dive into correcting the steam warnings in the OR log ( and yes mine looks just like yours Barrie )...these are easily correctable....follow Scott's engine file..I think that's the one I used. However, steam engines appear -- to me -- to operate just fine with OR making all the corrections, as shown in your log.

    Regarding your log from the Blue Comet route...you've got some signal entries that I do not have...that could be from an install problem...or something else..will need a signal expert to untangle it. No need to dump the route. As a matter of routine I always copy both the sigcfg.dat and sigscr.dat files into an "OpenRails" folder in the parent route folder.

    Wasn't there a signal update to the Blue Comet?
    Cheers, Gerry
    It's my railroad and I'll do what I want! Historically accurate attitude of US Railroad Barons.
    Forever, ridin' drag in railroad knowledge.


  8. #8

    Default

    G'day, Scott I will have a look at those attached files and your loco in the OR section and have a go at fixing them,thanks.
    Gerry I am also sure there was a signal upgrade but don't seem to be able to find it, thanks.
    Regards
    Barrie

  9. #9
    Join Date
    Apr 2003
    Location
    New York, USA.
    Posts
    2,172

    Default

    Quote Originally Posted by gremlin1812 View Post
    G'day, Scott I will have a look at those attached files and your loco in the OR section and have a go at fixing them,thanks.
    Gerry I am also sure there was a signal upgrade but don't seem to be able to find it, thanks.
    Regards
    Barrie
    Hi Barrie,

    Happy to help.

    If you have a locomotive in mind - you could take my files - rename them - and plug in values for the specific steam locomotive you're interested in. I've already filtered out all the old MSTS parameters that are no longer valid - to the best of my knowledge.

    For US Stuff - I get almost all my required prototype specifications from this site "Steam Locomotive":
    https://www.steamlocomotive.com/

    Then Peter's "Coals to Newcastle" is the definitive source for setting up ORTS physics - he has many "calculators" to obtain the proper values needed for your configuration:
    http://www.coalstonewcastle.com.au/

    Regards,
    Scott

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
-->