Results 1 to 3 of 3

Thread: FLIGHTSIM Forum Question

  1. #1
    Join Date
    Jan 2006
    Location
    Hanover Park, Il., USA.
    Posts
    9,632

    Default FLIGHTSIM Forum Question

    Hello
    I know Flightsim.com updated their forum recently, and I have not been able to login since.
    The new site asks to login with an e-mail address as your usrid, and I try, but it doesn't recognize either the address or the password. I try to have a new/temp password sent to the e-mail, but I never get a response.

    Any Flightsim folks out here have any suggestions?

    Thanks very much,
    Neil

    Here at home, in the railroad mayhem capital of the world.

  2. #2
    Join Date
    Jun 2001
    Location
    Yamba, N.S.WALES, Australia
    Posts
    4,784

    Default

    Quote Originally Posted by qballbandit View Post
    .....Any Flightsim folks out here have any suggestions?

    Thanks very much,
    Just a thought but how about registering under a new ID?
    You may need a different email address to your original, because you could get a response that the original is already registered.
    IBM XT i386; 512Kb RAM; 5.25" FDD; 1.4Mb FDD; 5Mb HDD; VGA 256-colour graphics card; AdLib soundcard; DR DOS 6.0; Windows 3.0

  3. #3
    Join Date
    Dec 2002
    Languages
    English, SQL
    Posts
    5,542

    Default

    There's been an ownership change at FlightSim as of last June. Nels is still contributing, but there are new admins in place handling all the day to day stuff.

    Looks like it's been a bit of a mess over the last three weeks since they made the software change.
    Last edited by eolesen; 02-06-2023 at 03:14 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •