Results 1 to 4 of 4

Thread: After failed install attempts in the past, MSTS surprised me this time

  1. #1
    Join Date
    Jun 2006
    Central, Connecticut, USA.

    Default After failed install attempts in the past, MSTS surprised me this time

    I've tried installing it on Windows 10 and on Window 11 in the past and its always failed to install but for some reason that is a mystery to me, It worked this time and works perfectly fine. My question obviously, did something change with Windows to allow it to work? Im surprised but happily surprised.
    Frank Roberts
    Charter member since day 1
    Driver, R&L Carriers
    Volunteer Ct Humane

  2. #2
    Join Date
    Sep 2005
    Gandangara Estate, Sutherland Shire. N.S.W, Australia.


    Hi Frank

    what was the failure, I know that some of my installs failed on the 2nd CD
    but when I just walked away and let it do it's thing it worked.

    Either way I'm happy for you, hopefully you are running MSTS in Openrails.


    Daniel - Sydney (Glad I'm not in Townsville)
    It used to be my favourite place in the world.

  3. #3
    Join Date
    Nov 1999
    Cumming Ga


    One way to likely always have a successful install is to NOT allow it to use the default installation directory.
    Just Blender now, 3DCrafter only when I have to.
    formerly The Keystone Works (All Permissions Granted)

  4. #4


    Hi Frank; Very pleased to hear that you got MSTS to install without a lot of fuss. My question is...Windows 11?
    I've tried many times to get it to install and run on Windows 11, but have had no luck. Did you do anything out of the ordinary to get it installed??
    Had no problems installing and running MSTS on Windows 10...just this new 11 thing!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts